Openwrt网络配置

/ 0评 / 0

DNS配置

uci add_list network.lan.dns="8.8.8.8,114.114.114.114"
uci commit network
ubus call network reload

效果: cat /etc/config/network
config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1 ra0 rai0'
        option proto 'static'
        option ipaddr '192.168.50.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        list dns '8.8.8.8,114.114.114.114'

静态IP配置

vim /etc/config/network
 
config interface 'lan'
        option ifname 'eth0.1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.50.1' # 更改
        option netmask '255.255.255.0'
        option ip6assign '60'

坑:修改完需要把这个路由及关联路由重启,以及电脑重启。要不然有连不上的可能。

二级路由同网段无线AP

参考: [OpenWrt Wiki] 无线接入点 / 哑接入点

重点:

  1. 二级路由ip为一级路由网段的ip
  2. 二级路由lan口的dhcp关闭
  3. 网线一级路由lan口连到二级路由lan

坑:设置完后二级路由的wifi默认变成关闭,需要手动重新打开

发表回复

您的电子邮箱地址不会被公开。